From 6c8fb23cc48969566fe373a09b7624d9677a5c28 Mon Sep 17 00:00:00 2001 From: Chirag Aggarwal Date: Thu, 22 Oct 2026 10:15:51 +0100 Subject: [PATCH] fix: bump vulnerable dependencies to patched versions black 25.11.0 is affected by GHSA-3936-cmfr-pm3m. Black 26 needs Python 3.10, so the test extra skips it on 3.9. --- pyproject.toml | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/pyproject.toml b/pyproject.toml index b75f237c..a963b294 100644 --- a/pyproject.toml +++ b/pyproject.toml @@ -35,7 +35,7 @@ classifiers = [ [project.optional-dependencies] test = [ - "black==25.11.0", + "black==26.10.1; python_version >= '3.10'", "requests_mock==1.11.0", ]