Skip to content
Open
Show file tree
Hide file tree
Changes from all commits
Commits
File filter

Filter by extension

Filter by extension


Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
2 changes: 1 addition & 1 deletion apps/code-of-conduct/package.json
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@
"@angular/common": "22.3.0-next.2",
"@angular/compiler": "22.3.0-next.2",
"@angular/core": "22.3.0-next.2",
"@angular/fire": "21.0.0-rc.2",
"@angular/fire": "21.0.0",

Copy link
Copy Markdown

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

high

Updating @angular/fire to 21.0.0 introduces a peer dependency conflict with the other Angular dependencies in this project. According to the release notes, @angular/[email protected] requires @angular/core and @angular/common version ^21.2.0 and TypeScript ^5.8.0 (below 6.0.0). However, this project is currently using @angular/[email protected] and [email protected]. Using @angular/fire v21 with Angular v22 can lead to runtime errors or compilation failures due to breaking changes in the major version of Angular. To resolve this, align the Angular version to ^21.2.0 or use a compatible pre-release version of @angular/fire that supports Angular v22.

"@angular/forms": "22.3.0-next.2",
"@angular/material": "22.3.0-next.3",
"@angular/platform-browser": "22.3.0-next.2",
Expand Down
4 changes: 2 additions & 2 deletions bazel/integration/tests/angular-cli/package.json
Original file line number Diff line number Diff line change
Expand Up @@ -22,8 +22,8 @@
"tslib": "^2.8.1"
},
"devDependencies": {
"@angular/build": "22.3.0-next.3",
"@angular/cli": "22.3.0-next.3",
"@angular/build": "22.3.0-next.4",
"@angular/cli": "22.3.0-next.4",
"@angular/compiler-cli": "22.3.0-next.2",
"@types/jasmine": "~6.0.0",
"@types/node": "24.19.2",
Expand Down
Loading
Loading