Repository navigation
[Snyk] Security upgrade urllib3 from 2.0.7 to 2.6.0 - #126
EVDOG4LIFE wants to merge 1 commit into
Conversation
The following vulnerabilities are fixed by pinning transitive dependencies: - https://snyk.io/vuln/SNYK-PYTHON-URLLIB3-14192442 - https://snyk.io/vuln/SNYK-PYTHON-URLLIB3-14192443
|
Important Review skippedIgnore keyword(s) in the title. Please check the settings in the CodeRabbit UI or the You can disable this status message by setting the ✨ Finishing touches🧪 Generate unit tests (beta)
Thanks for using CodeRabbit! It's free for OSS, and your support helps us grow. If you like it, consider giving us a shout-out. Comment |
|
Superseded by #168 and the published Python SDK 27.0.0 release: https://github.com/appwrite/sdk-for-python/releases/tag/27.0.0. Current main and release packaging require requests>=2.34.2,<3 and urllib3>=2.8.0,<3, which exceed the older minimum proposed here. Closing this historical dependency PR; applications still need to upgrade the SDK and use Python 3.10+. Audit tracking: https://github.com/appwrite-labs/cloud/issues/6887. |
Snyk has created this PR to fix 2 vulnerabilities in the pip dependencies of this project.
Snyk changed the following file(s):
requirements.txtImportant
Note: You are seeing this because you or someone else with access to this repository has authorized Snyk to open fix PRs.
For more information:
🧐 View latest project report
📜 Customise PR templates
🛠 Adjust project settings
📚 Read about Snyk's upgrade logic
Learn how to fix vulnerabilities with free interactive lessons:
🦉 Allocation of Resources Without Limits or Throttling