Skip to content
Merged
Changes from all commits
Commits
File filter

Filter by extension

Filter by extension

Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
13 changes: 11 additions & 2 deletions CHANGELOG.md
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,17 @@

## 27.0.0

* Breaking: raised the minimum supported Python version from 3.9 to 3.10
* Updated: required Requests >=2.34.2,<3 and urllib3 >=2.8.0,<3
This release updates the HTTP dependency requirements and raises the minimum supported Python version.

* **Breaking:** Python 3.9 is no longer supported. Upgrade to Python 3.10 or later before installing this release.
* **Security:** required `requests>=2.34.2,<3` and `urllib3>=2.8.0,<3` to exclude older dependency versions with known advisories. Update application dependency pins or constraints that prevent these versions from being installed.
* **Compatibility:** service methods, models, and response format `2.5.0` are unchanged from SDK 26.0.0. The SDK continues to target Appwrite 2.5.x.

To upgrade, activate a Python 3.10+ environment and run:

```sh
python -m pip install --upgrade "appwrite==27.0.0"
```

## 26.0.0

Expand Down
Loading